Announcement

Collapse
No announcement yet.

Sometimes this game is very slow for me.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Sometimes this game is very slow for me.

    It happens on all shakes & fidget servers for me. I can play days without noticing anything and then all of a sudden days on a row i have massive lag. I click on something and i gotta wait for around 30+ seconds before it does what i asked it.

    My internet is glassfiber 100Mbit/s and i have a 5870 with a i7 920 @3.6ghz. So its safe to assume my pc is more then capable of running this game. But on the other hand, i talked to people about this and they did not have it.

    Can anyone help me out on this? its been a real game breaker for me, i had thoughts on quitting several times.
    My chars:
    Fullpowerahead, 292 mage, s1: NL
    Fullpowerahead, 308 scout, s2: NL
    Fullpowerahead, 290 mage, s1: UK
    Fullpowerahead, 272 warrior, s2: UK

    #2
    Your computer specs don't have an influence on the game. All users have lag every now and then when our servers our maintained, updated or are temporarily slow. My internet connection is very fast but there are also days with temporary lag. Refreshing your browser window usually helps.
    Community and Social Media Manager

    Like and follow us on Facebook, Twitter and Instagram
    Community Discord server: https://discord.gg/XWfSwe3

    Comment


      #3
      I have the issue that currently the game takes up a large amount of my cpu time (like anywhere from 50-80%), with the result that my entire machine slows down to the point where the timer on the quests doesn't even update every second. This did not happen prior to a few days ago, so something must have changed?

      I'm using the Chrome browser on a respectable enough machine that a browser game should not lag it to death, particularly when I'm not actually interacting with the game.

      Comment


        #4
        I have the same problem. But for me it's only the co.uk server. It doesn't matter which browser you use!

        Comment


          #5
          Originally posted by ScrawnyRat View Post
          I have the issue that currently the game takes up a large amount of my cpu time (like anywhere from 50-80%), with the result that my entire machine slows down to the point where the timer on the quests doesn't even update every second. This did not happen prior to a few days ago, so something must have changed?

          I'm using the Chrome browser on a respectable enough machine that a browser game should not lag it to death, particularly when I'm not actually interacting with the game.
          How much RAM do you have?
          Community and Social Media Manager

          Like and follow us on Facebook, Twitter and Instagram
          Community Discord server: https://discord.gg/XWfSwe3

          Comment


            #6
            Originally posted by Leander View Post
            How much RAM do you have?
            2Gig. It's fine again today - maybe rebooting is all that was necessary? I don't really understand.

            Comment


              #7
              my guild mates and myself get lag too. and i got 6g of ram. Normally i see lag during guild fights. It gives that feeling like, "hes swinging his swooooooooooooooooorrrrrrrrrrrdddddddddddddddddd.. ................"

              Comment


                #8
                mine gets better for a while when i restart my browser
                but i have to do it 5-6-7 times a day

                Comment

                Working...
                X