Announcement

Collapse
No announcement yet.

Correct Area? :(

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Correct Area? :(

    SO it's the following, i have an acer aspire 5750G so i sohuld be able to run like Mw3 easely, and i do in-fact run it easely but i have sudden fps drops, like 10-20 seconds i play for like 10-20 fps, this happens from 5 to 5 minutes or so, does anyone know why?
    sigpic

    #2
    No, I don't know. Have you asked in the game's official forum?

    Shakes & Fidget Community Manager


    Like and follow us on Facebook, Twitter and Instagram

    Comment


      #3
      Originally posted by Leander View Post
      No, I don't know. Have you asked in the game's official forum?
      if it was just in one game :/, its in every game i play
      sigpic

      Comment


        #4
        Sounds like an internet or computer issue try checking with your ISP if thats ok then the maker of your computer
        have fun, fight hard, die honorably

        Comment


          #5
          Are your drivers up to date? Have you checked your computer for a possible trojan or virus infection?

          Are you downloading something while playing?

          etc...

          Shakes & Fidget Community Manager


          Like and follow us on Facebook, Twitter and Instagram

          Comment


            #6
            Originally posted by Leander View Post
            Are your drivers up to date? Have you checked your computer for a possible trojan or virus infection?

            Are you downloading something while playing?

            etc...
            I don't know if they are up to date, and if they aren't i don't know how to update them (im so noob), my pc is virus clean , and i only download stuff at night while sleeping (Yoho! Yoho! A pirate's night for me!)
            sigpic

            Comment

            Working...
            X